I’m getting a certificate error when trying to access the platform

If you are experiencing problems accessing our web platform due to a certificate error, we are aware of the following known issue which could be the cause.

The Let’s Encrypt root certificate (IdentTrust DST Root CA X3) is being phased out and is expected to expire on the 30th September 2021. Let’s Encrypt is used by many websites, browsers and web clients to encrypt your connection to the wider internet, including the UK Postbox platform and website. Devices expected to be affected by this expiry are restricted to those that aren’t regularly updated, such as smartphones running very old operating systems, older versions of macOS 2016, Windows XP (service pack 3), and those dependent on OpenSSL 1.0.2 or earlier.

We advise that you try to access the platform from a modern device running an up to date operating system and browser. If the problem continues to persist, please contact support.